dongzheng

662 经验值

 $attributes = [
            'trade_type'       => 'JSAPI', // JSAPI,NATIVE,APP...
            'body'             => '用户订单',
            'detail'           => 'iPad mini 16G 白色',
            'out_trade_no'     => time(),
            'total_fee'        => 1,
            'notify_url'       => 'http://disook.com/cart', // 支付结果通知网址,如果不设置则会使用配置里的默认地址
            //'sub_openid'        => $user->openid, // 如果传入sub_openid, 请在实例化Application时, 同时传入$sub_app_id, $sub_merchant_id
            // ...
        ];
        $order = new \EasyWeChat\Payment\Order($attributes);


        $result = $this->wechat->payment->prepare($order);
        dd($result);
        if ($result->return_code == 'SUCCESS' && $result->result_code == 'SUCCESS'){
            $prepayId = $result->prepay_id;

        }

返回签名错误

操作系统:Ubuntu 14.04,64位,谢谢,在线等!

按照你给的链接里的视频,当安装到:sudo apt-get install vim htop git;的时候就会报错。
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:

LANGUAGE = "en_US:",
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.

perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 121828 files and directories currently installed.)
Preparing to unpack .../vim_2%3a7.4.052-1ubuntu3.1_amd64.deb ...
Unpacking vim (2:7.4.052-1ubuntu3.1) over (2:7.4.052-1ubuntu3) ...

操作系统:Ubuntu 14.04,64位,laravel5.3 需要php5.6,但是Ubuntu默认的php版本是5.5.9,我想问怎么在安装的时候直接安装5.6.谢谢!

root@iZm5e1izxakc8pv0ueq1mqZ:/var/www/photo# php artisan cache:clear
PHP Warning: require(/var/www/photo/bootstrap/../vendor/autoload.php): failed to open stream: No such file or directory in /var/www/photo/bootstrap/autoload.php on line 17
PHP Fatal error: require(): Failed opening required '/var/www/photo/bootstrap/../vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/photo/bootstrap/autoload.php on line 17